Oil Pressure Warning Light - Yamaha R3 Forum
User Tag List

 
Thread Tools
post #1 of 9 Old 08-13-2015, 11:03 PM Thread Starter
Junior Member
 
Join Date: Aug 2015
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Oil Pressure Warning Light

I've just rolled over 30 miles on the bike and love it so far. It's my first street bike and after 10+ years of motocross and woods riding on dirt bikes I'm still adjusting.

Anyways, I hope I'm asking a stupid question and there's nothing actually wrong, but my oil pressure warning light stays on for 3 seconds after the engine is started. In the manual it says it should go off as soon as the engine is started, but I'm thinking its still flowing through the motor at that point no? Like I said its my first street bike and I'm probably just being over cautious but I'd like my mind to be put at ease. Thanks for any input!
yamazinger is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 08-14-2015, 12:41 AM
Junior Member
 
Join Date: Aug 2015
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Try to wait till the sound of the fuel pump stop after you turn the ignition key on. Then start the bike.
R3SG is offline  
post #3 of 9 Old 08-14-2015, 01:42 AM
Senior Member
 
Join Date: May 2015
Location: Bay Area, CA
Posts: 247
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 68 Post(s)
It's normal, afaicr.
Contrails is offline  
 
post #4 of 9 Old 08-14-2015, 05:28 AM
Member
 
Join Date: Mar 2015
Posts: 39
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Mine does it too. Also, my bike will stall out and seems to run lean when first getting on it at very low speeds. Lastly, at very low speeds it will pop or miss which I know is a lean condition. I've only had it a few weeks and it has 150 or so miles. One more thing. When it stalls at really low speed before it warms up. It will hesitate to start while in gear. Doesn't make sense to me, but every beast is different. My CB300F never had any type of issue besides top speed. I'm a Yamaha fan and love my R3, but don't think it should act like this. I'm a motocross guy too, so I'm used to getting the bike in neutral before attempting to start.
SquidOnR3 is offline  
post #5 of 9 Old 08-14-2015, 05:37 PM Thread Starter
Junior Member
 
Join Date: Aug 2015
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
I always wait for the fuel pump hum and the dash board to do its thing before I turn it over, it NEVER comes back on after the 3 seconds and I know the oil is at a good level. Thanks for the input!
yamazinger is offline  
post #6 of 9 Old 09-01-2015, 01:45 PM
Member
 
Join Date: Aug 2015
Posts: 31
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Cold start - Oil light goes out after 2-3 seconds.
Hot/warm start - oil light stays on 10-15 sec, until I rev a little.
Have seen it go out after rev (~2500-3000rpm) the come back on at idle.
Oil pressure sensor or oil pump?
Where can the actual oil pressure be checked (port)?
Mechanic is out sick for a couple days.
AgCat is offline  
post #7 of 9 Old 08-01-2016, 06:19 PM
Moderator
 
xorbe's Avatar
 
Join Date: May 2015
Location: Bay Area / Central Valley, CA, USA
Posts: 819
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 282 Post(s)
Quote:
Originally Posted by SquidOnR3 View Post
Also, my bike will stall out and seems to run lean when first getting on it at very low speeds.
Another case, yeah my R3 will cut out and buck me badly if I get on the gas within the first ~30 seconds if the engine is cold, so now I let my bike warm up to 2 bars first before departing. Also I had to adjust the idle set screw to raise idle rpms from 1300 to 1800 to stop the bike from stalling at stop lights all the time, super dangerous. Yamaha needs to revisit fueling/afr at idle.

I notice that the poster hasn't returned in 9 months, must have changed bikes.

oh hai, yo
xorbe is offline  
post #8 of 9 Old 01-06-2017, 01:24 AM
Junior Member
 
Join Date: Nov 2016
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Quote:
Originally Posted by xorbe View Post
Another case, yeah my R3 will cut out and buck me badly if I get on the gas within the first ~30 seconds if the engine is cold, so now I let my bike warm up to 2 bars first before departing. Also I had to adjust the idle set screw to raise idle rpms from 1300 to 1800 to stop the bike from stalling at stop lights all the time, super dangerous. Yamaha needs to revisit fueling/afr at idle.

I notice that the poster hasn't returned in 9 months, must have changed bikes.
Where is this screw?
dexter is offline  
post #9 of 9 Old 01-10-2017, 02:18 PM
Moderator
 
xorbe's Avatar
 
Join Date: May 2015
Location: Bay Area / Central Valley, CA, USA
Posts: 819
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 282 Post(s)
Quote:
Originally Posted by dexter View Post
Where is this screw?
iirc, Follow the throttle cable to the engine. You'll need to remove a fairing and the coolant reservoir. The set screw is where the rotating throttle stops. You'll need to wedge the throttle open while trying to work with the microscopic set screw. Thin fingers will help.

oh hai, yo
xorbe is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Yamaha R3 Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



  Similar Threads
Thread Thread Starter Forum Replies Last Post
TST Industries getting a jump start on creation of integrated tail light and other YZ TSTagent TST Industries 69 07-26-2016 12:06 PM
Chain Lube and Tire Pressure PSA ebarros What Did You Do To Your Yamaha R3 Today? 20 07-19-2016 11:22 PM
Efficient RPM shift? Timing Light. John Drivetrain 18 03-22-2016 03:19 PM
Oil Light Still Blinking After Change ebarros Oil and Lube 11 08-28-2015 10:32 AM
How do I set my shift light on my R3 Jeff1010 Yamaha R3 How To & DIY 2 07-26-2015 12:24 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are Off