Yamaha R3 Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey guys new poster here,

Have had my r3 for a few years now and the battery got so weak it wouldn’t turn over. Replaced the battery now and I get nothing. No screen, no pump sound literally nothing. Any tips??
 

·
Super Moderator
Joined
·
909 Posts
Welcome to the Forum. You need to verify the battery is good. If it is, it's probably the Main Fuse 30A. It's under the panel between the front and rear seat. NOT the 30A in the fuse holder tray.. That one is a Spare 30A. The one you're looking for is inline with the starter relay. You'd be better off reading through the owner's manual for instructions and a visual for what you're looking for. I have a link below for a 2015 R3 owners manual. It'll work for you, no matter the year model, for what you're trying to find. Good Luck
https://cdn.yamaha-motor.eu/owner-manuals/Motorcycles/PB02F8199E0E.PDF
 

·
Registered
Joined
·
40 Posts
Did you replace it with a lead battery that requires you to fill it with acid before use?

What's the voltage of the new battery?
 

·
Registered
Joined
·
6 Posts
I first would try to check the negative (-) connection if you can snug it better and try again,
If it's a bit loose you won't be able to start the bike, it can cause your engine to shut due to riding if you did manage to start it.
 

·
Registered
Joined
·
91 Posts
Hey guys new poster here,

Have had my r3 for a few years now and the battery got so weak it wouldn’t turn over. Replaced the battery now and I get nothing. No screen, no pump sound literally nothing. Any tips??
If its a lithium battery, many don't ship with a charge. With that in mind, you will need to charge it prior to use. Be sure to use a lithium-compatible charger though.
 

·
Registered
Joined
·
374 Posts
The idea that works for me is to Start Simple Stupid. Did you accidentally bump the kill switch to the off position on the handlebars during this time?
 
1 - 6 of 6 Posts
Top