Yamaha R3 Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I've clocked 800 miles on my bike and it was fine until 3 days ago. My bike will turn off automatically as soon as i start releasing the clutch in 1st gear. The engine simply turns off without lurching forward like normal stalling. It will stay running with the clutch pulled in in 1st gear. This problem repeats the same thing until the 4th of 5th try of restarting. and also it will throw code 19 on the dash. But once it is back to normal it would ride fine. Until yesterday when it happened when i was trying to move off from my driveway. I've tried checking the side stand switch and found nothing wrong with it. It will just turn off as soon as i start releasing the clutch even before hitting the friction zone. Anyone ever encounter this problem? I've had a friend in Malaysia riding an R25 which essentially is the same bike and he had encountered this same problem recently yet and the weird thing is that R25 in Malaysia didn't come equipped with side stand switch. Hence i believe it isn't the side stand switch which is causing the problem. Any help here would be very much appreciated.
 

·
Registered
Joined
·
542 Posts
Side stand switch is the code you are getting. Check for any loose wires, and clean up all the connections. Could just be dirt or grime somewhere, or a cable that came loose.

Also, pm sent
 

·
Registered
Joined
·
7 Posts
i can confirm this turning off on my bike since the firs day, now i let it warming before starting ride, it got better now.
 

·
Registered
Joined
·
169 Posts
I've clocked 800 miles on my bike and it was fine until 3 days ago. My bike will turn off automatically as soon as i start releasing the clutch in 1st gear. The engine simply turns off without lurching forward like normal stalling. It will stay running with the clutch pulled in in 1st gear. This problem repeats the same thing until the 4th of 5th try of restarting. and also it will throw code 19 on the dash. But once it is back to normal it would ride fine. Until yesterday when it happened when i was trying to move off from my driveway. I've tried checking the side stand switch and found nothing wrong with it. It will just turn off as soon as i start releasing the clutch even before hitting the friction zone. Anyone ever encounter this problem? I've had a friend in Malaysia riding an R25 which essentially is the same bike and he had encountered this same problem recently yet and the weird thing is that R25 in Malaysia didn't come equipped with side stand switch. Hence i believe it isn't the side stand switch which is causing the problem. Any help here would be very much appreciated.
The same thing happened for my friend after the recall service was done, his bike did not start at all for several tries. Somehow he was able to reach the service center. It showed code 19.
They tried to check everything anyway nothing worked.
In the end they had to replace the ECU and now no issues yet.
 

Attachments

·
Registered
Joined
·
33 Posts
There is also a switch in the clutch lever perch that may may stick. The switch allows you to restar the bike in any gear as long as you pull in the lever.
 
1 - 7 of 7 Posts
Top