Yamaha R3 Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Problem 1: My indicators won't turn on and stay on.

Problem 2: On the dashboard, when I signal left or right both left and right lights blink (like hazards on a car).

Background: I previously bought some LED bulbs at the auto store and put them on the bike. Never noticed anything until a few months later that the indicators don't stay on. I can signal left and right though but they don't stay on like they should so I decided to try and put the factory bulbs back but I couldn't find it so I bought some 7440 bulbs and put them on. Now the indicators still don't stay on, I can't signal left or right (including dashboard) and my brake light doesn't work. I took it to the shop and they said that it was a fuse and that everything was working. They were closing so I took it and didn't test it out but when I got home. I could see that I can now signal left and right and the brake lights come on but the indicators don't stay on and the dashboard left and right both come on whenever i signal left or right.

See how the indicators stay on in this pic below:
 

·
Registered
Joined
·
175 Posts
Info from this post http://www.r3-forums.com/forum/289-...fe-flush-mount-turn-signals-2.html#post410801 states that the front bulbs are 7443, a dual filament bulb as they function as both a blinker and a drl. A 7440 bulb will only function as a blinker.

The dash indicator does not differentiate between left and right. It's only there to let you know a turn signal is activated.
This^^^^
7443 fronts and 7440 rear.
Also, when you went LED did you purchase the LED flasher module? Also, also, LED's are polarity specific and will only work when inserted in the proper orientation. Always replace one bulb at a time, test for proper operation, then replace the next bulb and so on and so on.
 

·
Registered
Joined
·
18 Posts
Discussion Starter · #4 ·
Thanks. I lost the oem front indicator bulbs so I just looked on the back ones which were 7440 which I know were OEM cause i didn't replace it. I will try the 7443 for the fronts tomorrow and report back.

If I put 7443 for the fronts should the rear indicators stay on as well? 'cause currently the 7440 on the rear don't stay on.

I did not have the LED flasher module. I did not know I needed it but once I get it fixed I plan to put LED's again. One step at a time :)
 

·
Registered
Joined
·
175 Posts
The rears should remain off until you signal, then they will flash. The fronts will stay on (bike running) then flash brighter when you signal.
 
1 - 6 of 6 Posts
Top