Yamaha R3 Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 · (Edited)
I just noticed the other day that my front turn signals stay on like running lights all the time, but the rear ones don't. Normal?
Also, I got TST flush mounts for the front and a relay, but keeping the stock signals on the rear for now. TST shows you the different combos that the relay will work with, but they don't include after market fronts w/stock rear signals. Anyone have this setup?
Thanks for any replies.

My bad. I just went through the show your ride thread and could see the answers to both my questions.
 

·
Registered
Joined
·
12 Posts
Bump here but I'm running into the same problem here and can't find the solution that he found.. installed tst flush mounts a few weeks ago and could have sworn that both my front and my rear running lights were working but just tonight I noticed that my rear running lights WEREN'T working and my front tst flush mounts WERE running. Activating the turn signal will cause both front and back signals to blink like new, it's just the running lights in the rear that don't work. Anyone know what's wrong?
 

·
Super Moderator
Joined
·
1,391 Posts
I bought the Euro Yamaha LED Blinker Plus setup for this very reason. I wanted running lights front AND back at all times. They have nice white ones in the front and red ones in the back.

If anyone is thinking of installing these the best thing to do is get the TST adapters and their flasher module as the resistors it comes with don't really do anything for the hyper flashing.

The red in the back is awesome - very bright and also works as an added brake light. Front and rear have separate turn signals too.
 

·
Registered
Joined
·
163 Posts
I bought the Euro Yamaha LED Blinker Plus setup for this very reason. I wanted running lights front AND back at all times. They have nice white ones in the front and red ones in the back.

If anyone is thinking of installing these the best thing to do is get the TST adapters and their flasher module as the resistors it comes with don't really do anything for the hyper flashing.

The red in the back is awesome - very bright and also works as an added brake light. Front and rear have separate turn signals too.
How Did you do the wiring for the rear lights please? I got the Rizoma 3 function signal lights. I was able to wire the amber signal light using the TST bullet to OEM Harness, super easy, but now I have to wire the brake and running light to the OEM wires 'without' a harness. I'm trying to avoid having to 'cut' or even use POSI-TAP type of connections since my bike is still under warrenty.
I'm going to go to an electronic store at some point and also ask for ideas too. I know the connector for the tail light is a MT090, if they sell a male/female, I'll get them to make me a Y split for the brake light - that would be awesome.
 

·
Registered
Joined
·
261 Posts
How Did you do the wiring for the rear lights please? I got the Rizoma 3 function signal lights. I was able to wire the amber signal light using the TST bullet to OEM Harness, super easy, but now I have to wire the brake and running light to the OEM wires 'without' a harness. I'm trying to avoid having to 'cut' or even use POSI-TAP type of connections since my bike is still under warrenty.
I'm going to go to an electronic store at some point and also ask for ideas too. I know the connector for the tail light is a MT090, if they sell a male/female, I'll get them to make me a Y split for the brake light - that would be awesome.
The connector you're looking for is a Sumitomo mt090 3 pin. That will mate to the original Yamaha harness. This bike uses a heck ton of sumitomo connectors.
 

·
Registered
Joined
·
163 Posts
The connector you're looking for is a Sumitomo mt090 3 pin. That will mate to the original Yamaha harness. This bike uses a heck ton of sumitomo connectors.
Salaam Muhammad! thanks for the info!
That is the pin for sure! I just hope it is easily available in my local market - online orders are super delayed.
 

·
Registered
Joined
·
261 Posts
Salam Tazmtl! These connectors aren't common so I would suggest buying a couple and keep them around for spares or in case you crimp them badly. These are waterproof connectors so remember to run the wires through the provided rubber seals and crimp them on the pins before inserting into the connector housing.
 

·
Registered
Joined
·
163 Posts
Salam Tazmtl! These connectors aren't common so I would suggest buying a couple and keep them around for spares or in case you crimp them badly. These are waterproof connectors so remember to run the wires through the provided rubber seals and crimp them on the pins before inserting into the connector housing.
Thanks for the tip! I'll make sure I do so. Ended up ordering 4 sets online - I''m going to have to build my own Y split with bullet ends whenever the order gets here.
The electronic store did not have it as you suspected!
 

·
Registered
Joined
·
163 Posts
Thanks for the tip! I'll make sure I do so. Ended up ordering 4 sets online - I''m going to have to build my own Y split with bullet ends whenever the order gets here.
The electronic store did not have it as you suspected!
I couldn't wait for the connectors to show up - they still haven't shipped!
Weather was bad for the past few days, so I decided to make my own connectors and the tail light wires! I was able to source a pair of MT090 connectors from TST Industries (amazing customer service btw got it in 3 days) There were basically part of their brake modulator. I un-cliped the wires I didn't didn't need by using a flat head and unlocking the pins in the MT090 and ran a straight 3 wire connection male to female. I also bought T-TAP connectors from the local electronic store with some 22 gauge wire and some spade connector that fits into the T-TAP. Once I was able to make two sets of wires, each set has one end has two female bullets for my Rizoma lights and the other end a spade connector - I 'sliced' 2 t-taps into the harness -Brake(red wire & /Running light(blue wire) I modded from TST,
If someone is interested, I can upload pics of the stuff I used. The only wires that got 'sliced' are the ones between the extra male to female MT090. If I decide to go back to stock one day (only reason I can think of is 'IF' I ever sell), I just remove that joint and click the OEM tail light mt090 to the OEM receiver; like nothing every happened lol. Now my rear indicators are also working as day lights as well as well an additional brake light! Anything to remain visible!
 

·
Registered
Joined
·
261 Posts
Its kind of a shitty time to be shipping stuff from overseas. I'm waiting on a replacement rectifier and wiring harness. My local dealer did not have any in stock and their markup is insane. Also, their estimated waiting time is 4 months. Ain't nobody got time for that!
 

·
Registered
Joined
·
163 Posts
Its kind of a shitty time to be shipping stuff from overseas. I'm waiting on a replacement rectifier and wiring harness. My local dealer did not have any in stock and their markup is insane. Also, their estimated waiting time is 4 months. Ain't nobody got time for that!
That really sucks! I'm not smart enough to know what a rectifier is, I just hope your ride still works fine!
 
1 - 12 of 12 Posts
Top